p PatchFirst

CVE-2026-33924

CVE-2026-33924 · Authenticated RCE in update functionality in Guardian/CMC before 26.4.0

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Two OS command injection vulnerabilities were discovered in the update installation functionality due to insufficient validation of the update bundle contents. An attacker with administrative privileges can remotely supply a crafted update bundle that, when installed, causes arbitrary commands to be executed with root privileges, allowing the attacker to read or modify sensitive data, change the appliance configuration, or shut down the appliance.

CVSS 7.5 · High · EPSS 1.1% · Fix available

Published
Updated

Affected products and versions

  • guardian

    Versions
    • ≥ 0, < 26.4.0: Affected (semver)

    Update to 26.4.0

  • cmc

    Versions
    • ≥ 0, < 26.4.0: Affected (semver)

    Update to 26.4.0

Original sources

Check your server →