CVE-2026-34179
CVE-2026-34179 · Update of type field in restricted TLS certificate allows privilege escalation to cluster admin
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Canonical LXD versions 4.12 through 6.7, the doCertificateUpdate function in lxd/certificates.go does not validate the Type field when handling PUT/PATCH requests to /1.0/certificates/{fingerprint} for restricted TLS certificate users, allowing a remote authenticated attacker to escalate privileges to cluster admin.
CVSS 9.1 · Critical · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
lxd
- Versions
- ≥ 4.12.0, < 5.0.7: Affected (semver)
- ≥ 5.1.0, < 5.21.5: Affected (semver)
- ≥ 6.0.0, < 6.8.0: Affected (semver)
Update to 5.0.7; Update to 5.21.5; Update to 6.8.0
incus Debian:13
- Versions
- 6.0.4-2
- 6.0.4-2+deb13u1
- 6.0.4-2+deb13u1~bpo12+1
- 6.0.4-2+deb13u2
- 6.0.4-2+deb13u2~bpo12+1
- 6.0.4-2+deb13u3
- 6.0.4-2+deb13u3~bpo12+1
- 6.0.4-2+deb13u4
- 6.0.4-2+deb13u4~bpo12+1
- 6.0.4-2+deb13u5
- 6.0.4-2+deb13u5~bpo12+1
- 6.0.4-2+deb13u6~bpo12+1
- Affected ranges
- ECOSYSTEM: < 6.0.4-2+deb13u6
Update to 6.0.4-2+deb13u6
incus Debian:14
- Versions
- 6.0.4-2
- 6.0.4-3
- 6.0.5-1
- 6.0.5-2
- 6.0.5-3
- 6.0.5-4
- 6.0.5-5
- 6.0.5-6
- 6.0.5-7
- 6.0.5-8
- 6.0.6-1
- 6.0.6-2
- Affected ranges
- ECOSYSTEM: < 6.0.6-3
Update to 6.0.6-3
lxd Debian:12
- Versions
- 5.0.2+git20231211.1364ae4-1
- 5.0.2+git20231211.1364ae4-2
- 5.0.2+git20231211.1364ae4-3
- 5.0.2+git20231211.1364ae4-4
- 5.0.2+git20231211.1364ae4-5
- 5.0.2+git20231211.1364ae4-6
- 5.0.2+git20231211.1364ae4-7
- 5.0.2+git20231211.1364ae4-8
- 5.0.2+git20231211.1364ae4-9
- 5.0.2-5
- 5.0.2-5+deb12u1
- 5.0.2-5+deb12u2
- 5.0.2-5+deb12u3
- 5.0.2-5+deb12u4
- 5.0.2-5+deb12u5
- 5.0.2-5+deb12u6
- 5.0.2-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
lxd Debian:13
- Versions
- 5.0.2+git20231211.1364ae4-9
- 5.0.2+git20231211.1364ae4-9+deb13u1
- 5.0.2+git20231211.1364ae4-9+deb13u2
- 5.0.2+git20231211.1364ae4-9+deb13u3
- 5.0.2+git20231211.1364ae4-9+deb13u4
- Affected ranges
- ECOSYSTEM: < 5.0.2+git20231211.1364ae4-9+deb13u5
Update to 5.0.2+git20231211.1364ae4-9+deb13u5
incus Ubuntu:Pro:24.04:LTS
- Versions
- 0.4-1ubuntu1
- 0.5.1-1
- 0.5.1-3
- 0.6-1
- 6.0.0-1
- 6.0.0-1ubuntu0.1
- 6.0.0-1ubuntu0.2
- 6.0.0-1ubuntu0.2+esm1
- 6.0.0-1ubuntu0.3
- 6.0.0-1ubuntu0.3+esm1
- 6.0.0-1ubuntu0.3+esm2
- 6.0.0-1ubuntu0.3+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
incus Ubuntu:25.10
- Versions
- 6.0.3-4
- 6.0.4-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
incus Ubuntu:26.10
- Versions
- 6.0.5-8
- 7.0.1-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
incus Ubuntu:Pro:26.04:LTS
- Versions
- 6.0.4-2
- 6.0.5-8
- 6.0.5-8ubuntu0.26.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published