CVE-2026-35433
CVE-2026-35433 · .NET Elevation of Privilege Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper input validation in .NET allows an unauthorized attacker to elevate privileges locally.
CVSS 7.3 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
.net 10.0
- Versions
- ≥ 10.0.0, < 10.0.8: Affected (custom)
Update to 10.0.8
.net 8.0
- Versions
- ≥ 8.0.0, < 8.0.27: Affected (custom)
Update to 8.0.27
.net 9.0
- Versions
- ≥ 9.0.0, < 9.0.16: Affected (custom)
Update to 9.0.16
microsoft .net framework 3.5
- Versions
- ≥ 3.5.0, < 4.8.9334.0 and 4.8.4802.0: Affected (custom)
Update to 4.8.9334.0 and 4.8.4802.0
microsoft .net framework 3.5 and 4.7.2
- Versions
- ≥ 4.7.0, < 4.8.9334.0 and 4.8.4802.0: Affected (custom)
Update to 4.8.9334.0 and 4.8.4802.0
microsoft .net framework 3.5 and 4.8
- Versions
- ≥ 4.8.0, < 4.8.9334.0 and 4.8.4802.0: Affected (custom)
Update to 4.8.9334.0 and 4.8.4802.0
microsoft .net framework 3.5 and 4.8.1
- Versions
- ≥ 4.8.1, < 4.8.9334.0 and 4.8.4802.0: Affected (custom)
Update to 4.8.9334.0 and 4.8.4802.0
microsoft .net framework 4.8
- Versions
- ≥ 4.8.0, < 4.8.9334.0 and 4.8.4802.0: Affected (custom)
Update to 4.8.9334.0 and 4.8.4802.0
dotnet7 Ubuntu:22.04:LTS
- Versions
- 7.0.105-0ubuntu1~22.04.1
- 7.0.107-0ubuntu1~22.04.1
- 7.0.108-0ubuntu1~22.04.1
- 7.0.109-0ubuntu1~22.04.1
- 7.0.110-0ubuntu1~22.04.1
- 7.0.111-0ubuntu1~22.04.1
- 7.0.112-0ubuntu1~22.04.1
- 7.0.113-0ubuntu1~22.04.1
- 7.0.114-0ubuntu1~22.04.1
- 7.0.115-0ubuntu1~22.04.1
- 7.0.116-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.2
- 7.0.119-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published