p PatchFirst

CVE-2026-35621

CVE-2026-35621 · OpenClaw < 2026.3.24 - Privilege Escalation via chat.send to Allowlist Persistence

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.24 contains a privilege escalation vulnerability where the /allowlist command fails to re-validate gateway client scopes for internal callers, allowing operator.write-scoped clients to mutate channel authorization policy. Attackers can exploit chat.send to build an internal command-authorized context and persist channel allowFrom and groupAllowFrom policy changes reserved for operator.admin scope.

CVSS 7.1 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.24: Affected (semver)
    • 2026.3.24: Not affected (semver)

    Update to 2026.3.24

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.24

    Update to 2026.3.24

Original sources

Check your server →