p PatchFirst

CVE-2026-35622

CVE-2026-35622 · OpenClaw < 2026.3.22 - Improper Authentication Verification in Google Chat Webhook

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.22 contains an improper authentication verification vulnerability in Google Chat app-url webhook handling that accepts add-on principals outside intended deployment bindings. Attackers can bypass webhook authentication by providing non-deployment add-on principals to execute unauthorized actions through the Google Chat integration.

CVSS 6.0 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.22: Affected (semver)
    • 2026.3.22: Not affected (semver)

    Update to 2026.3.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.22

    Update to 2026.3.22

Original sources

Check your server →