p PatchFirst

CVE-2026-35638

CVE-2026-35638 · OpenClaw < 2026.3.22 - Privilege Escalation via Self-Declared Scopes in Trusted-Proxy Control UI

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.22 contains a privilege escalation vulnerability in the Control UI that allows unauthenticated sessions to retain self-declared privileged scopes without device identity verification. Attackers can exploit the device-less allow path in the trusted-proxy mechanism to maintain elevated permissions by declaring arbitrary scopes, bypassing device identity requirements.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.22: Affected (semver)
    • 2026.3.22: Not affected (semver)

    Update to 2026.3.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.22

    Update to 2026.3.22

Original sources

Check your server →