p PatchFirst

CVE-2026-35639

CVE-2026-35639 · OpenClaw < 2026.3.22 - Privilege Escalation via device.pair.approve Scope Validation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.22 contains a privilege escalation vulnerability in the device.pair.approve method that allows an operator.pairing approver to approve pending device requests with broader operator scopes than the approver actually holds. Attackers can exploit insufficient scope validation to escalate privileges to operator.admin and achieve remote code execution on the Node infrastructure.

CVSS 8.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.22: Affected (semver)
    • 2026.3.22: Not affected (semver)

    Update to 2026.3.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.22

    Update to 2026.3.22

Original sources

Check your server →