p PatchFirst

CVE-2026-35641

CVE-2026-35641 · OpenClaw < 2026.3.24 - Arbitrary Code Execution via .npmrc in Local Plugin/Hook Installation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.24 contains an arbitrary code execution vulnerability in local plugin and hook installation that allows attackers to execute malicious code by crafting a .npmrc file with a git executable override. During npm install execution in the staged package directory, attackers can leverage git dependencies to trigger execution of arbitrary programs specified in the attacker-controlled .npmrc configuration file.

CVSS 8.4 · High · EPSS 0.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.24: Affected (semver)
    • 2026.3.24: Not affected (semver)

    Update to 2026.3.24

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.24

    Update to 2026.3.24

Original sources

Check your server →