p PatchFirst

CVE-2026-35645

CVE-2026-35645 · OpenClaw < 2026.3.25 - Privilege Escalation via Synthetic operator.admin in deleteSession

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that uses a synthetic operator.admin runtime scope. Attackers can exploit this by triggering session deletion without a request-scoped client to execute privileged operations with unintended administrative scope.

CVSS 6.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.25: Affected (semver)
    • 2026.3.25: Not affected (semver)

    Update to 2026.3.25

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.28

    Update to 2026.3.28

Original sources

Check your server →