p PatchFirst

CVE-2026-35650

CVE-2026-35650 · OpenClaw < 2026.3.22 - Environment Variable Override Bypass via Inconsistent Sanitization

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.22 contains an environment variable override handling vulnerability that allows attackers to bypass the shared host environment policy through inconsistent sanitization paths. Attackers can supply blocked or malformed override keys that slip through inconsistent validation to execute arbitrary code with unintended environment variables.

CVSS 7.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.22: Affected (semver)
    • 2026.3.22: Not affected (semver)

    Update to 2026.3.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.22

    Update to 2026.3.22

Original sources

Check your server →