p PatchFirst

CVE-2026-35651

CVE-2026-35651 · OpenClaw 2026.2.13 < 2026.3.25 - ANSI Escape Sequence Injection in Approval Prompt

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions 2026.2.13 through 2026.3.24 contain an ANSI escape sequence injection vulnerability in approval prompts that allows attackers to spoof terminal output. Untrusted tool metadata can carry ANSI control sequences into approval prompts and permission logs, enabling attackers to manipulate displayed information through malicious tool titles.

CVSS 5.3 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 2026.2.13, ≤ 2026.3.24: Affected (semver)
    • 2026.3.25: Not affected (semver)

    Update to 2026.3.25

  • openclaw npm

    Affected ranges
    • SEMVER: ≥ 2026.2.13, < 2026.3.28

    Update to 2026.3.28

Original sources

Check your server →