p PatchFirst

CVE-2026-35663

CVE-2026-35663 · OpenClaw < 2026.3.25 - Privilege Escalation via Backend Reconnect Scope Self-Claim

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.25 contains a privilege escalation vulnerability allowing non-admin operators to self-request broader scopes during backend reconnect. Attackers can bypass pairing requirements to reconnect as operator.admin, gaining unauthorized administrative privileges.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.25: Affected (semver)
    • 2026.3.25: Not affected (semver)

    Update to 2026.3.25

  • openclaw npm

    Affected ranges
    • SEMVER: ≤ 2026.3.24

    No fix published

Original sources

Check your server →