p PatchFirst

CVE-2026-35669

CVE-2026-35669 · OpenClaw < 2026.3.25 - Privilege Escalation via Gateway Plugin HTTP Authentication Scope

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in gateway-authenticated plugin HTTP routes that incorrectly mint operator.admin runtime scope regardless of caller-granted scopes. Attackers can exploit this scope boundary bypass to gain elevated privileges and perform unauthorized administrative actions.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.25: Affected (semver)
    • 2026.3.25: Not affected (semver)

    Update to 2026.3.25

  • openclaw npm

    Affected ranges
    • SEMVER: ≤ 2026.3.24

    No fix published

Original sources

Check your server →