p PatchFirst

CVE-2026-3691

CVE-2026-3691 · OpenClaw Client PKCE Verifier Information Disclosure Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw Client PKCE Verifier Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose stored credentials on affected installations of OpenClaw. User interaction is required to exploit this vulnerability in that the target must initiate an OAuth authorization flow. The specific flaw exists within the implementation of OAuth authorization. The issue results from the exposure of sensitive data in the authorization URL query string. An attacker can leverage this vulnerability to disclose stored credentials, leading to further compromise. Was ZDI-CAN-29381.

CVSS 5.3 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • 2026.2.21: Affected

    No fix published

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.25

    Update to 2026.2.25

Original sources

Check your server →