p PatchFirst

CVE-2026-39413

CVE-2026-39413 · LightRAG has a JWT Algorithm Confusion Vulnerability in LightRAG API

This page contains facts from public vulnerability sources. Check the original advisory before updating.

LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.4.14, the LightRAG API is vulnerable to a JWT algorithm confusion attack where an attacker can forge tokens by specifying 'alg': 'none' in the JWT header. Since the jwt.decode() call does not explicitly deny the 'none' algorithm, a crafted token without a signature will be accepted as valid, leading to unauthorized access. This vulnerability is fixed in 1.4.14.

CVSS 4.2 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • lightrag

    Versions
    • < 1.4.14: Affected

    No fix published

  • lightrag-hku PyPI

    Versions
    • 0.0.2
    • 0.0.3
    • 0.0.4
    • 0.0.5
    • 0.0.6
    • 0.0.7
    • 0.0.8
    • 0.0.9
    • 1.0.0
    • 1.0.1
    • 1.0.3
    • 1.0.5
    • 1.0.6
    • 1.0.8
    • 1.0.9
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.6
    • 1.1.7
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.2.5
    • 1.2.6
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.3.5
    • 1.3.6
    • 1.3.7
    • 1.3.8
    • 1.3.9
    • 1.4.0
    • 1.4.1
    • 1.4.10
    • 1.4.11
    • 1.4.11rc2
    • 1.4.12
    • 1.4.12rc1
    • 1.4.13
    • 1.4.13rc1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.4.5
    • 1.4.6
    • 1.4.7
    • 1.4.8.1
    • 1.4.8.2
    • 1.4.8rc4
    • 1.4.8rc6
    • 1.4.8rc7
    • 1.4.8rc8
    • 1.4.8rc9
    • 1.4.9
    • 1.4.9.1
    • 1.4.9.10
    • 1.4.9.11
    • 1.4.9.2
    • 1.4.9.3
    • 1.4.9.4
    • 1.4.9.4rc1
    • 1.4.9.5
    • 1.4.9.6
    • 1.4.9.7
    • 1.4.9.8
    • 1.4.9.9
    • 1.4.9rc1
    • 1.4.9rc2
    • 1.4.9rc3
    • 1.4.9rc4
    Affected ranges
    • ECOSYSTEM: < 1.4.14

    Update to 1.4.14

Original sources

Check your server →