CVE-2026-3965
CVE-2026-3965 · whyour qinglong API express.ts protection mechanism
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A security vulnerability has been detected in whyour qinglong up to 2.20.1. Affected is an unknown function of the file back/loaders/express.ts of the component API Interface. The manipulation of the argument command leads to protection mechanism failure. The attack may be initiated remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.20.2 is able to address this issue. The identifier of the patch is 6bec52dca158481258315ba0fc2f11206df7b719. It is advisable to upgrade the affected component. The code maintainer was informed beforehand about the issues. He reacted very fast and highly professional.
CVSS 5.3 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
qinglong
- Versions
- 2.20.0: Affected
- 2.20.1: Affected
- 2.20.2: Not affected
Update to 2.20.2
@whyour/qinglong npm
- Affected ranges
- SEMVER: < 2.20.2
Update to 2.20.2
Original sources
- https://vuldb.com/?id.350394
- https://vuldb.com/?ctiid.350394
- https://vuldb.com/?submit.768861
- https://github.com/A7cc/cve/issues/6
- https://github.com/whyour/qinglong/pull/2941
- https://github.com/A7cc/cve/issues/6#issue-3999235307
- https://github.com/whyour/qinglong/commit/6bec52dca158481258315ba0fc2f11206df7b719
- https://github.com/whyour/qinglong/releases/tag/v2.20.2
- https://github.com/whyour/qinglong/
- https://nvd.nist.gov/vuln/detail/CVE-2026-3965