p PatchFirst

CVE-2026-39921

CVE-2026-39921 · GeoNode < 4.4.5, 5.0.2 SSRF via Document Upload

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GeoNode versions 4.0 before 4.4.5 and 5.0 before 5.0.2 contain a server-side request forgery vulnerability that allows authenticated users with document upload permissions to trigger arbitrary outbound HTTP requests by providing a malicious URL via the doc_url parameter during document upload. Attackers can supply URLs pointing to internal network targets, loopback addresses, RFC1918 addresses, or cloud metadata services to cause the server to make requests to internal resources without SSRF mitigations such as private IP filtering or redirect validation.

CVSS 5.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • geonode

    Versions
    • ≥ 4.0.0, < 4.4.5: Affected (semver)
    • ≥ 5.0.0, < 5.0.2: Affected (semver)

    Update to 4.4.5; Update to 5.0.2

  • geonode PyPI

    Versions
    • 4.0.0
    • 4.0.0.post1
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.1.0
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.1.3.post1
    • 4.1.4
    • 4.1.5
    • 4.2.0
    • 4.2.1
    • 4.2.2
    • 4.2.3
    • 4.2.4
    • 4.2.5
    • 4.3.0
    • 4.3.0.post1
    • 4.3.1
    • 4.4.0
    • 4.4.1
    • 4.4.2
    • 4.4.3
    • 4.4.4
    • 5.0.0
    • 5.0.1
    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0, < 4.4.5 ∪ ≥ 5.0.0, < 5.0.2

    Update to 4.4.5; Update to 5.0.2

Original sources

Check your server →