CVE-2026-40036
CVE-2026-40036 · Unfurl < 2026.04 - Denial of Service via Unbounded zlib Decompression
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Unfurl before 2026.04 contains an unbounded zlib decompression vulnerability in parse_compressed.py that allows remote attackers to cause denial of service. Attackers can submit highly compressed payloads via URL parameters to the /json/visjs endpoint that expand to gigabytes, exhausting server memory and crashing the service.
CVSS 8.7 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
unfurl
- Versions
- ≥ 0, < 2026.04: Affected (custom)
Update to 2026.04
dfir-unfurl PyPI
- Versions
- 20200629
- 20200630
- 20200630.2
- 20200630.3
- 20200630.4
- 20200702
- 20200703
- 20200729
- 20200812
- 20201102
- 20210308
- 20210309
- 20210310
- 20210311
- 20210615
- 20220200
- 20221100
- 20230900
- 20230901
- 20240625
- 20240626
- 20240627
- 20241120
- 20241121
- 20250218
- 20250312
- 20250810
- Affected ranges
- ECOSYSTEM: < 20260405
Update to 20260405