p PatchFirst

CVE-2026-40217

CVE-2026-40217

This page contains facts from public vulnerability sources. Check the original advisory before updating.

LiteLLM through 2026-04-08 allows remote attackers to execute arbitrary code via bytecode rewriting at the /guardrails/test_custom_code URI.

CVSS 8.8 · High · EPSS 15.5% · Public exploit · Fix available

Published
Updated

Stack: python

Affected products and versions

  • litellm

    Versions
    • bb0639701796218a3447160e55c0f1097446e4e6085df7dfd39f476d4143743f: Affected (custom)

    No fix published

  • litellm PyPI

    Versions
    • 1.81.10
    • 1.81.11
    • 1.81.12
    • 1.81.13
    • 1.81.14
    • 1.81.15
    • 1.81.16
    • 1.81.8
    • 1.81.9
    • 1.81.9.dev1
    • 1.82.0
    • 1.82.1
    • 1.82.2
    • 1.82.3
    • 1.82.4
    • 1.82.5
    • 1.82.6
    • 1.83.0
    • 1.83.1
    • 1.83.2
    • 1.83.3
    • 1.83.4
    • 1.83.5
    • 1.83.6
    • 1.83.7
    • 1.83.8
    • 1.83.9
    Affected ranges
    • ECOSYSTEM: ≥ 1.81.8, < 1.83.10

    Update to 1.83.10

Original sources

Check your server →