p PatchFirst

CVE-2026-40887

CVE-2026-40887 · @vendure/core has a SQL Injection vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Vendure is an open-source headless commerce platform. Starting in version 1.7.4 and prior to versions 2.3.4, 3.5.7, and 3.6.2, an unauthenticated SQL injection vulnerability exists in the Vendure Shop API. A user-controlled query string parameter is interpolated directly into a raw SQL expression without parameterization or validation, allowing an attacker to execute arbitrary SQL against the database. This affects all supported database backends (PostgreSQL, MySQL/MariaDB, SQLite). The Admin API is also affected, though exploitation there requires authentication. Versions 2.3.4, 3.5.7, and 3.6.2 contain a patch. For those who are unable to upgrade immediately, Vendure has made a hotfix available that uses `RequestContextService.getLanguageCode` to validate the `languageCode` input at the boundary. This blocks injection payloads before they can reach any query. The hotfix replaces the existing `getLanguageCode` method in `packages/core/src/service/helpers/request-context/request-context.service.ts`. Invalid values are silently dropped and the channel's default language is used instead. The patched versions additionally convert the vulnerable SQL interpolation to a parameterized query as defense in depth.

CVSS 9.1 · Critical · EPSS 1.8% · Public exploit · Fix available

Published
Updated

Stack: node

Affected products and versions

  • vendure

    Versions
    • >= 3.0.0, < 3.5.7: Affected
    • >= 3.6.0, < 3.6.2: Affected
    • >= 1.7.4, < 2.3.4: Affected

    No fix published

  • @vendure/core npm

    Affected ranges
    • SEMVER: ≥ 3.0.0, < 3.5.7

    Update to 3.5.7

  • @vendure/core npm

    Affected ranges
    • SEMVER: ≥ 3.6.0, < 3.6.2

    Update to 3.6.2

  • @vendure/core npm

    Affected ranges
    • SEMVER: ≥ 1.7.4, < 2.3.4

    Update to 2.3.4

Original sources

Check your server →