CVE-2026-40994
CVE-2026-40994 · Wss4jSecurityInterceptor disables WS-I BSP validation by default
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Wss4jSecurityInterceptor initialized its BSP (WS-I Basic Security Profile) compliance flag so that inbound validation disabled WSS4J BSP enforcement on RequestData. Services that validate WS-Security on the network could therefore accept messages that violate BSP rules, weakening protocol-level checks. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.
CVSS 8.2 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
spring web services
- Versions
- ≥ 5.0.0, < 5.0.1.1: Affected (custom)
- ≥ 4.1.0, < 4.1.3.1: Affected (custom)
- ≥ 4.0.0, < 4.0.19: Affected (custom)
- ≥ 3.1.0, < 3.1.9: Affected (custom)
Update to 3.1.9; Update to 4.0.19; Update to 4.1.3.1; Update to 5.0.1.1
its Ubuntu:16.04:LTS
- Versions
- 1.1.8-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
its Ubuntu:18.04:LTS
- Versions
- 1.1.8-6build1
- 1.1.8-6.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
its Ubuntu:20.04:LTS
- Versions
- 1.1.8-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published