p PatchFirst

CVE-2026-41138

CVE-2026-41138 · Flowise: Remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas.

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, there is a remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas. The user’s input is directly applied to the question parameter within the prompt template and it is reflected to the Python code without any sanitization. This vulnerability is fixed in 3.1.0.

CVSS 8.3 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • flowise

    Versions
    • < 3.1.0: Affected

    No fix published

  • flowise npm

    Affected ranges
    • SEMVER: < 3.1.0

    Update to 3.1.0

  • flowise-components npm

    Affected ranges
    • SEMVER: < 3.1.0

    Update to 3.1.0

Original sources

Check your server →