CVE-2026-41142
CVE-2026-41142 · OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From versions 3.0.0 to before 3.2.9, 3.3.0 to before 3.3.11, and 3.4.0 to before 3.4.11, there is an integer overflow in ImageChannel::resize that leads to heap OOB write via OpenEXRUtil public API. This issue has been patched in versions 3.2.9, 3.3.11, and 3.4.11.
CVSS 8.8 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
openexr
- Versions
- >= 3.0.0, < 3.2.9: Affected
- >= 3.3.0, < 3.3.11: Affected
- >= 3.4.0, < 3.4.11: Affected
No fix published
openexr Debian:12
- Versions
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Debian:13
- Versions
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Debian:14
- Versions
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Affected ranges
- ECOSYSTEM: < 3.4.14-0.1
Update to 3.4.14-0.1
openexr Ubuntu:Pro:16.04:LTS
- Versions
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- 2.2.0-10ubuntu2.1
- 2.2.0-10ubuntu2.2
- 2.2.0-10ubuntu2.3
- 2.2.0-10ubuntu2.4
- 2.2.0-10ubuntu2.6
- 2.2.0-10ubuntu2.6+esm1
- 2.2.0-10ubuntu2.6+esm2
- 2.2.0-10ubuntu2.6+esm3
- 2.2.0-10ubuntu2.6+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:18.04:LTS
- Versions
- 2.2.0-11ubuntu1
- 2.2.0-11.1ubuntu1
- 2.2.0-11.1ubuntu1.1
- 2.2.0-11.1ubuntu1.2
- 2.2.0-11.1ubuntu1.3
- 2.2.0-11.1ubuntu1.4
- 2.2.0-11.1ubuntu1.6
- 2.2.0-11.1ubuntu1.7
- 2.2.0-11.1ubuntu1.8
- 2.2.0-11.1ubuntu1.9
- 2.2.0-11.1ubuntu1.9+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:20.04:LTS
- Versions
- 2.2.1-4.1ubuntu1
- 2.3.0-6
- 2.3.0-6build1
- 2.3.0-6ubuntu0.1
- 2.3.0-6ubuntu0.2
- 2.3.0-6ubuntu0.3
- 2.3.0-6ubuntu0.5
- 2.3.0-6ubuntu0.5+esm1
- 2.3.0-6ubuntu0.5+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:22.04:LTS
- Versions
- 2.5.4-2
- 2.5.7-1
- 2.5.7-1ubuntu0.1~esm1
- 2.5.7-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:24.04:LTS
- Versions
- 3.1.5-5.1
- 3.1.5-5.1build1
- 3.1.5-5.1build2
- 3.1.5-5.1build3
- 3.1.5-5.1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:25.10
- Versions
- 3.1.13-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:26.10
- Versions
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:26.04:LTS
- Versions
- 3.1.13-2
- 3.1.13-2build1
- 3.1.13-2ubuntu0.26.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-m25w-72cj-q6mg
- https://github.com/AcademySoftwareFoundation/openexr/pull/2367
- https://github.com/AcademySoftwareFoundation/openexr/commit/0592ee539f33c122c90f09238579b902d838afb4
- https://access.redhat.com/security/cve/CVE-2026-41142
- https://bugzilla.redhat.com/show_bug.cgi?id=2467623
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41142.json
- https://access.redhat.com/errata/RHSA-2026:39024
- https://access.redhat.com/errata/RHSA-2026:38499
- https://access.redhat.com/errata/RHSA-2026:39027
- https://access.redhat.com/errata/RHSA-2026:39026
- https://access.redhat.com/errata/RHSA-2026:39025
- https://access.redhat.com/errata/RHSA-2026:38498
- https://nvd.nist.gov/vuln/detail/CVE-2026-41142