CVE-2026-41213
CVE-2026-41213 · @node-oauth/oauth2-server: PKCE code_verifier ABNF not enforced in token exchange allows brute-force redemption of intercepted authorization codes
This page contains facts from public vulnerability sources. Check the original advisory before updating.
@node-oauth/oauth2-server is a module for implementing an OAuth2 server in Node.js. The token exchange path accepts RFC7636-invalid code_verifier values (including one-character strings) for S256 PKCE flows. Because short/weak verifiers are accepted and failed verifier attempts do not consume the authorization code, an attacker who intercepts an authorization code can brute-force code_verifier guesses online until token issuance succeeds.
CVSS 5.9 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
node-oauth2-server
- Versions
- < 5.3.0: Affected
No fix published
@node-oauth/oauth2-server npm
- Affected ranges
- SEMVER: < 5.3.0
Update to 5.3.0