CVE-2026-41292
CVE-2026-41292 · Long list of incoming EDNS options degrades performance
This page contains facts from public vulnerability sources. Check the original advisory before updating.
NLnet Labs Unbound up to and including version 1.25.0 is vulnerable to a degradation of service attack related to parsing long lists of incoming EDNS options. An adversary sending queries with too many EDNS options can hold Unbound threads hostage while they are parsing and creating internal data structures for the options. Coordinated attacks can result in degradation and/or denial of service. Unbound 1.25.1 contains a patch with a fix to limit acceptable incoming EDNS options (100).
CVSS 6.6 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
unbound
- Versions
- ≥ 0, < 1.25.1: Affected (semver)
Update to 1.25.1
unbound Debian:12
- Versions
- 1.17.1-2
- 1.17.1-2+deb12u1
- 1.17.1-2+deb12u2
- 1.17.1-2+deb12u3
- 1.17.1-2+deb12u4
- 1.17.1-2+loong64
- 1.18.0-1
- 1.18.0-2
- 1.19.1-1
- 1.19.2-1
- 1.20.0-1
- 1.21.1-1
- 1.22.0-1
- 1.22.0-2
- 1.23.1-1
- 1.24.0-1
- 1.24.0-2
- 1.24.1-1
- 1.24.1-2
- 1.24.2-1
- 1.25.0-1
- 1.25.1-1
- 1.25.2-1
- 1.26.0-1
- 1.26.0-2
- 1.26.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
unbound Debian:13
- Versions
- 1.22.0-2
- 1.22.0-2+deb13u1
- 1.22.0-2+deb13u2
- Affected ranges
- ECOSYSTEM: < 1.22.0-2+deb13u3
Update to 1.22.0-2+deb13u3
unbound Debian:14
- Versions
- 1.22.0-2
- 1.23.1-1
- 1.24.0-1
- 1.24.0-2
- 1.24.1-1
- 1.24.1-2
- 1.24.2-1
- 1.25.0-1
- Affected ranges
- ECOSYSTEM: < 1.25.1-1
Update to 1.25.1-1
unbound Ubuntu:Pro:18.04:LTS
- Versions
- 1.6.5-1
- 1.6.7-1
- 1.6.7-1build1
- 1.6.7-1ubuntu1
- 1.6.7-1ubuntu2
- 1.6.7-1ubuntu2.1
- 1.6.7-1ubuntu2.2
- 1.6.7-1ubuntu2.3
- 1.6.7-1ubuntu2.4
- 1.6.7-1ubuntu2.5
- 1.6.7-1ubuntu2.6
- 1.6.7-1ubuntu2.6+esm2
- 1.6.7-1ubuntu2.6+esm3
- Affected ranges
- ECOSYSTEM: < 1.6.7-1ubuntu2.6+esm4
Update to 1.6.7-1ubuntu2.6+esm4
unbound Ubuntu:Pro:20.04:LTS
- Versions
- 1.9.0-2ubuntu1
- 1.9.0-2ubuntu2
- 1.9.4-2
- 1.9.4-2ubuntu1
- 1.9.4-2ubuntu1.1
- 1.9.4-2ubuntu1.2
- 1.9.4-2ubuntu1.3
- 1.9.4-2ubuntu1.4
- 1.9.4-2ubuntu1.5
- 1.9.4-2ubuntu1.6
- 1.9.4-2ubuntu1.8
- 1.9.4-2ubuntu1.9
- 1.9.4-2ubuntu1.11
- Affected ranges
- ECOSYSTEM: < 1.9.4-2ubuntu1.11+esm1
Update to 1.9.4-2ubuntu1.11+esm1
unbound Ubuntu:22.04:LTS
- Versions
- 1.13.1-1ubuntu1
- 1.13.1-1ubuntu3
- 1.13.1-1ubuntu5
- 1.13.1-1ubuntu5.1
- 1.13.1-1ubuntu5.2
- 1.13.1-1ubuntu5.3
- 1.13.1-1ubuntu5.4
- 1.13.1-1ubuntu5.5
- 1.13.1-1ubuntu5.7
- 1.13.1-1ubuntu5.8
- 1.13.1-1ubuntu5.10
- 1.13.1-1ubuntu5.11
- 1.13.1-1ubuntu5.12
- 1.13.1-1ubuntu5.13
- 1.13.1-1ubuntu5.14
- Affected ranges
- ECOSYSTEM: < 1.13.1-1ubuntu5.15
Update to 1.13.1-1ubuntu5.15
unbound Ubuntu:24.04:LTS
- Versions
- 1.17.1-2
- 1.18.0-2ubuntu1
- 1.18.0-2ubuntu2
- 1.19.1-1ubuntu1
- 1.19.2-1ubuntu1
- 1.19.2-1ubuntu3
- 1.19.2-1ubuntu3.1
- 1.19.2-1ubuntu3.2
- 1.19.2-1ubuntu3.3
- 1.19.2-1ubuntu3.4
- 1.19.2-1ubuntu3.5
- 1.19.2-1ubuntu3.6
- 1.19.2-1ubuntu3.7
- Affected ranges
- ECOSYSTEM: < 1.19.2-1ubuntu3.8
Update to 1.19.2-1ubuntu3.8
unbound Ubuntu:25.10
- Versions
- 1.22.0-1ubuntu1
- 1.22.0-2ubuntu1
- 1.22.0-2ubuntu2
- 1.22.0-2ubuntu2.1
- 1.22.0-2ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 1.22.0-2ubuntu2.3
Update to 1.22.0-2ubuntu2.3
unbound Ubuntu:26.04:LTS
- Versions
- 1.22.0-2ubuntu2
- 1.22.0-2ubuntu4
- 1.24.2-1ubuntu1
- 1.24.2-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.24.2-1ubuntu2.1
Update to 1.24.2-1ubuntu2.1
Original sources
- https://www.nlnetlabs.nl/downloads/unbound/CVE-2026-41292.txt
- https://access.redhat.com/security/cve/CVE-2026-41292
- https://bugzilla.redhat.com/show_bug.cgi?id=2480125
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41292.json
- https://access.redhat.com/errata/RHSA-2026:54769
- https://access.redhat.com/errata/RHSA-2026:36320
- https://access.redhat.com/errata/RHSA-2026:37282
- https://access.redhat.com/errata/RHSA-2026:36777
- https://access.redhat.com/errata/RHSA-2026:24013
- https://nvd.nist.gov/vuln/detail/CVE-2026-41292