p PatchFirst

CVE-2026-41302

CVE-2026-41302 · OpenClaw < 2026.3.31 - Server-Side Request Forgery via Unguarded fetch() in Marketplace Plugin Download

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.31 contains a server-side request forgery vulnerability in the marketplace plugin download functionality that allows remote attackers to make arbitrary network requests. Attackers can exploit unguarded fetch() calls to access internal resources or interact with external services on behalf of the affected system.

CVSS 4.8 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.31: Affected (semver)
    • 2026.3.31: Not affected (semver)

    Update to 2026.3.31

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.31

    Update to 2026.3.31

Original sources

Check your server →