CVE-2026-41324
CVE-2026-41324 · basic-ftp vulnerable to denial of service via unbounded memory consumption in Client.list()
This page contains facts from public vulnerability sources. Check the original advisory before updating.
basic-ftp is an FTP client for Node.js. Versions prior to 5.3.0 are vulnerable to denial of service through unbounded memory growth while processing directory listings from a remote FTP server. A malicious or compromised server can send an extremely large or never-ending listing response to `Client.list()`, causing the client process to consume memory until it becomes unstable or crashes. Version 5.3.0 fixes the issue.
CVSS 7.5 · High · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
basic-ftp
- Versions
- < 5.3.0: Affected
No fix published
node-proxy-agents Debian:13
- Versions
- 0~2024040606-6
- 0~2024040606-6+deb13u1
- 0~2025070717+~cs15.2.7-1
- 0~2025070717+~cs15.3.7-1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- 0~2025070717+~cs16.2.9-1
- 0~2025070717-1
- 0~2025070717-2
- 0~2025070717-3
- 0~2025070717-4
- 0~2025070717-5
- 0~2025070717-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-proxy-agents Debian:14
- Versions
- 0~2024040606-6
- 0~2025070717+~cs15.2.7-1
- 0~2025070717-1
- 0~2025070717-2
- 0~2025070717-3
- 0~2025070717-4
- 0~2025070717-5
- 0~2025070717-6
- Affected ranges
- ECOSYSTEM: < 0~2025070717+~cs15.3.7-1
Update to 0~2025070717+~cs15.3.7-1
basic-ftp npm
- Affected ranges
- SEMVER: < 5.3.0
Update to 5.3.0
node-proxy-agents Ubuntu:24.04:LTS
- Versions
- 0~2023071921-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-proxy-agents Ubuntu:25.10
- Versions
- 0~2024040606-5
- 0~2024040606-6
- 0~2025070717-1
- 0~2025070717-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-proxy-agents Ubuntu:26.10
- Versions
- 0~2025070717+~cs15.2.7-1build1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-proxy-agents Ubuntu:26.04:LTS
- Versions
- 0~2025070717-2
- 0~2025070717-6
- 0~2025070717+~cs15.2.7-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published