p PatchFirst

CVE-2026-41343

CVE-2026-41343 · OpenClaw < 2026.3.31 - Denial of Service via LINE Webhook Handler Pre-Auth Concurrency

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.31 lacks a shared pre-auth concurrency budget on the public LINE webhook path, allowing attackers to cause transient availability loss. Remote attackers can flood the webhook endpoint with concurrent requests before signature verification to exhaust resources and degrade service availability.

CVSS 6.9 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.31: Affected (semver)
    • 2026.3.31: Not affected (semver)

    Update to 2026.3.31

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.31

    Update to 2026.3.31

Original sources

Check your server →