p PatchFirst

CVE-2026-41344

CVE-2026-41344 · OpenClaw < 2026.3.28 - Privilege Escalation via chat.send /verbose Parameter

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.28 contains a privilege escalation vulnerability in the chat.send endpoint that allows write-scoped gateway callers to persist admin-only verboseLevel session overrides. Attackers can exploit the /verbose parameter to bypass access controls and expose sensitive reasoning or tool output intended to be restricted to administrators.

CVSS 5.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.28: Affected (semver)
    • 2026.3.28: Not affected (semver)

    Update to 2026.3.28

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.28

    Update to 2026.3.28

Original sources

Check your server →