p PatchFirst

CVE-2026-41378

CVE-2026-41378 · OpenClaw < 2026.3.31 - Privilege Escalation to Remote Code Execution via Unrestricted node.event Agent Dispatch

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.31 contains a privilege escalation vulnerability allowing paired nodes with role=node to dispatch node.event agent requests with unrestricted gateway-side tool access. Attackers with trusted paired node credentials can escalate privileges by leveraging unrestricted agent.request dispatch to achieve remote code execution on the gateway.

CVSS 7.7 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.31: Affected (semver)
    • 2026.3.31: Not affected (semver)

    Update to 2026.3.31

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.31

    Update to 2026.3.31

Original sources

Check your server →