p PatchFirst

CVE-2026-41386

CVE-2026-41386 · OpenClaw < 2026.3.22 - Privilege Escalation via Unbound Bootstrap Setup Codes

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles and scopes during pairing. Attackers can exploit this during first-use device pairing to escalate privileges beyond their intended role and scope.

CVSS 9.1 · Critical · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.22: Affected (semver)
    • 2026.3.22: Not affected (semver)

    Update to 2026.3.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.22

    Update to 2026.3.22

Original sources

Check your server →