p PatchFirst

CVE-2026-41390

CVE-2026-41390 · OpenClaw < 2026.3.28 - Exec Allowlist Bypass via Unregistered /usr/bin/script Wrapper

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.28 contains an exec allowlist bypass vulnerability where allow-always persistence fails to unwrap /usr/bin/script and similar wrappers before storing trust decisions. Attackers can obtain user approval for one wrapped command to persist trust for wrapper binaries that execute different underlying programs.

CVSS 7.0 · High · EPSS 0.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.28: Affected (semver)
    • 2026.3.28: Not affected (semver)

    Update to 2026.3.28

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.28

    Update to 2026.3.28

Original sources

Check your server →