p PatchFirst

CVE-2026-41394

CVE-2026-41394 · OpenClaw < 2026.3.31 - Unauthorized Operator Scope Access in Unauthenticated Plugin-Auth Routes

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.31 contains an authentication bypass vulnerability where unauthenticated plugin-auth HTTP routes receive operator runtime write scopes. Attackers can access these routes without authentication to perform privileged runtime actions intended for authorized operators.

CVSS 8.8 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.31: Affected (semver)
    • 2026.3.31: Not affected (semver)

    Update to 2026.3.31

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.31

    Update to 2026.3.31

Original sources

Check your server →