p PatchFirst

CVE-2026-41404

CVE-2026-41404 · OpenClaw < 2026.3.31 - Operator Admin Privilege Escalation via Trusted-Proxy Authentication

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.31 contains an incomplete scope-clearing vulnerability in trusted-proxy authentication mode that allows operator.admin privilege escalation. Attackers can exploit this by declaring operator scopes on non-Control-UI clients, allowing self-declared scopes to persist on identity-bearing authentication paths and escalate privileges.

CVSS 7.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.31: Affected (semver)
    • 2026.3.31: Not affected (semver)

    Update to 2026.3.31

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.31

    Update to 2026.3.31

Original sources

Check your server →