p PatchFirst

CVE-2026-41500

CVE-2026-41500 · electerm has Command Injection Vulnerability via runMac function

This page contains facts from public vulnerability sources. Check the original advisory before updating.

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:150. The runMac() function appends attacker-controlled remote releaseInfo.name directly into an exec("open ...") command without validation. This issue has been patched in version 3.3.8.

CVSS 9.8 · Critical · EPSS 1.6% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • electerm

    Versions
    • < 3.3.8: Affected

    No fix published

  • electerm npm

    Affected ranges
    • SEMVER: < 3.3.8

    Update to 3.3.8

Original sources

Check your server →