CVE-2026-41674
CVE-2026-41674 · xmldom: XML injection through unvalidated DocumentType serialization
This page contains facts from public vulnerability sources. Check the original advisory before updating.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In @xmldom/xmldom prior to versions 0.9.10 and 0.8.13 and xmldom version 0.6.0 and prior, the package serializes DocumentType node fields (internalSubset, publicId, systemId) verbatim without any escaping or validation. When these fields are set programmatically to attacker-controlled strings, XMLSerializer.serializeToString can produce output where the DOCTYPE declaration is terminated early and arbitrary markup appears outside it. This issue has been patched in versions @xmldom/xmldom versions 0.9.10 and 0.8.13.
CVSS 8.7 · High · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
xmldom
- Versions
- xmldom <= 0.6.0: Affected
- @xmldom/xmldom >= 0.9.0, < 0.9.10: Affected
- @xmldom/xmldom < 0.8.13: Affected
No fix published
node-xmldom Debian:12
- Versions
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Debian:13
- Versions
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Debian:14
- Versions
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: < 0.9.10-1
Update to 0.9.10-1
@xmldom/xmldom npm
- Affected ranges
- SEMVER: < 0.8.13
Update to 0.8.13
@xmldom/xmldom npm
- Affected ranges
- SEMVER: ≥ 0.9.0, < 0.9.10
Update to 0.9.10
xmldom npm
- Affected ranges
- SEMVER: ≤ 0.6.0
No fix published
node-xmldom Ubuntu:20.04:LTS
- Versions
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:22.04:LTS
- Versions
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:24.04:LTS
- Versions
- 0.8.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:25.10
- Versions
- 0.9.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.10
- Versions
- 0.9.8-2
- 0.9.10-2
- 0.9.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.04:LTS
- Versions
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/xmldom/xmldom/security/advisories/GHSA-f6ww-3ggp-fr8h
- https://github.com/xmldom/xmldom/commit/372008f9ae0e20fd69f761c7b79e202598267314
- https://github.com/xmldom/xmldom/releases/tag/0.8.13
- https://github.com/xmldom/xmldom/releases/tag/0.9.10
- https://access.redhat.com/security/cve/CVE-2026-41674
- https://bugzilla.redhat.com/show_bug.cgi?id=2467620
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41674.json
- https://access.redhat.com/errata/RHSA-2026:21338
- https://access.redhat.com/errata/RHSA-2026:26234
- https://access.redhat.com/errata/RHSA-2026:21703
- https://access.redhat.com/errata/RHSA-2026:20034
- https://nvd.nist.gov/vuln/detail/CVE-2026-41674