p PatchFirst

CVE-2026-41908

CVE-2026-41908 · OpenClaw < 2026.4.20 - Scope Enforcement Bypass in Assistant-Media Route

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.20 contains a scope enforcement bypass vulnerability in the assistant-media route that allows trusted-proxy callers without operator.read scope to access protected assistant-media files and metadata. Attackers can bypass identity-bearing HTTP auth path scope validation to retrieve sensitive media content within allowed media roots.

CVSS 2.3 · Low · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.20: Affected (semver)
    • 2026.4.20: Not affected (semver)

    Update to 2026.4.20

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.20

    Update to 2026.4.20

Original sources

Check your server →