p PatchFirst

CVE-2026-41909

CVE-2026-41909 · OpenClaw < 2026.4.20 - Improper Authorization in Paired-Device Pairing Actions

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.20 contains an improper authorization vulnerability in paired-device pairing management that allows limited-scope sessions to enumerate and act on pairing requests. Attackers with paired-device access can approve or operate on unrelated pending device requests within the same gateway scope.

CVSS 5.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.20: Affected (semver)
    • 2026.4.20: Not affected (semver)

    Update to 2026.4.20

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.20

    Update to 2026.4.20

Original sources

Check your server →