p PatchFirst

CVE-2026-42203

CVE-2026-42203 · LiteLLM: Server-Side Template Injection in /prompts/test endpoint

This page contains facts from public vulnerability sources. Check the original advisory before updating.

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.80.5 to before version 1.83.7, the POST /prompts/test endpoint accepted user-supplied prompt templates and rendered them without sandboxing. A crafted template could run arbitrary code inside the LiteLLM Proxy process. The endpoint only checks that the caller presents a valid proxy API key, so any authenticated user could reach it. Depending on how the proxy is deployed, this could expose secrets in the process environment (such as provider API keys or database credentials) and allow commands to be run on the host. This issue has been patched in version 1.83.7.

CVSS 8.6 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • litellm

    Versions
    • >= 1.80.5, < 1.83.7: Affected

    No fix published

  • litellm PyPI

    Versions
    • 1.80.10
    • 1.80.11
    • 1.80.12
    • 1.80.13
    • 1.80.15
    • 1.80.16
    • 1.80.17
    • 1.80.5
    • 1.80.6
    • 1.80.7
    • 1.80.8
    • 1.80.9
    • 1.81.0
    • 1.81.1
    • 1.81.10
    • 1.81.11
    • 1.81.12
    • 1.81.13
    • 1.81.14
    • 1.81.15
    • 1.81.16
    • 1.81.3
    • 1.81.4
    • 1.81.5
    • 1.81.6
    • 1.81.7
    • 1.81.8
    • 1.81.9
    • 1.81.9.dev1
    • 1.82.0
    • 1.82.1
    • 1.82.2
    • 1.82.3
    • 1.82.4
    • 1.82.5
    • 1.82.6
    • 1.83.0
    • 1.83.1
    • 1.83.2
    • 1.83.3
    • 1.83.4
    • 1.83.5
    • 1.83.6
    Affected ranges
    • ECOSYSTEM: ≥ 1.80.5, < 1.83.7

    Update to 1.83.7

Original sources

Check your server →