CVE-2026-42271
CVE-2026-42271 · LiteLLM: Authenticated command execution via MCP stdio test endpoints
This page contains facts from public vulnerability sources. Check the original advisory before updating.
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
CVSS 8.7 · High · EPSS 91.4% · In KEV · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
litellm
- Versions
- >= 1.74.2, < 1.83.7: Affected
No fix published
litellm PyPI
- Versions
- 1.74.12
- 1.74.14
- 1.74.15
- 1.74.15.post1
- 1.74.15.post2
- 1.74.2
- 1.74.3
- 1.74.3.post1
- 1.74.3rc1
- 1.74.3rc2
- 1.74.3rc3
- 1.74.4
- 1.74.4.dev1
- 1.74.6
- 1.74.7
- 1.74.7.post1
- 1.74.7.post2
- 1.74.7rc1
- 1.74.8
- 1.74.8.dev2
- 1.74.9
- 1.74.9.dev1
- 1.74.9.dev2
- 1.74.9.post1
- 1.74.9.post2
- 1.75.0
- 1.75.2
- 1.75.3
- 1.75.4
- 1.75.5.post1
- 1.75.5.post2
- 1.75.6
- 1.75.7
- 1.75.8
- 1.75.9
- 1.76.0
- 1.76.1
- 1.76.2
- 1.76.3
- 1.77.0
- 1.77.1
- 1.77.2.post1
- 1.77.3
- 1.77.4
- 1.77.4.dev1
- 1.77.5
- 1.77.7
- 1.78.0
- 1.78.0rc2
- 1.78.2
- 1.78.3
- 1.78.4
- 1.78.5
- 1.78.6
- 1.78.7
- 1.79.0
- 1.79.0.dev1
- 1.79.0.dev2
- 1.79.0.dev3
- 1.79.1
- 1.79.2
- 1.79.3
- 1.79.3.dev8
- 1.80.0
- 1.80.10
- 1.80.11
- 1.80.12
- 1.80.13
- 1.80.15
- 1.80.16
- 1.80.17
- 1.80.5
- 1.80.6
- 1.80.7
- 1.80.8
- 1.80.9
- 1.81.0
- 1.81.1
- 1.81.10
- 1.81.11
- 1.81.12
- 1.81.13
- 1.81.14
- 1.81.15
- 1.81.16
- 1.81.3
- 1.81.4
- 1.81.5
- 1.81.6
- 1.81.7
- 1.81.8
- 1.81.9
- 1.81.9.dev1
- 1.82.0
- 1.82.1
- 1.82.2
- 1.82.3
- 1.82.4
- 1.82.5
- 1.82.6
- 1.83.0
- 1.83.1
- 1.83.2
- 1.83.3
- 1.83.4
- 1.83.5
- 1.83.6
- Affected ranges
- ECOSYSTEM: ≥ 1.74.2, < 1.83.7
Update to 1.83.7
Original sources
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271
- https://access.redhat.com/security/cve/CVE-2026-42271
- https://bugzilla.redhat.com/show_bug.cgi?id=2467924
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json
- https://access.redhat.com/errata/RHSA-2026:28960
- https://access.redhat.com/errata/RHSA-2026:30056
- https://access.redhat.com/errata/RHSA-2026:27784
- https://nvd.nist.gov/vuln/detail/CVE-2026-42271