p PatchFirst

CVE-2026-42280

CVE-2026-42280 · Improper Permission Checking in Auth.js SDK

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.

CVSS 7.1 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • auth0.js

    Versions
    • >= 8.11.0 , <= 9.32.0: Affected

    No fix published

  • auth0-js npm

    Affected ranges
    • SEMVER: ≥ 8.11.0, < 10.0.0

    Update to 10.0.0

Original sources

Check your server →