CVE-2026-42334
CVE-2026-42334 · Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.
CVSS 7.5 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
mongoose
- Versions
- < 6.13.9: Affected
- >= 7.0.0, <= 7.8.8: Affected
- >= 8.0.0, <= 8.22.0: Affected
- >= 9.0.0, <= 9.1.5: Affected
No fix published
mongoose npm
- Affected ranges
- SEMVER: < 6.13.9
Update to 6.13.9
mongoose npm
- Affected ranges
- SEMVER: ≥ 7.0.0, < 7.8.9
Update to 7.8.9
mongoose npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.22.1
Update to 8.22.1
mongoose npm
- Affected ranges
- SEMVER: ≥ 9.0.0, < 9.1.6
Update to 9.1.6