p PatchFirst

CVE-2026-42426

CVE-2026-42426 · OpenClaw < 2026.4.8 - Improper Authorization in node.pair.approve via operator.write Scope

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.8 contains an improper authorization vulnerability where the node.pair.approve method accepts operator.write scope instead of the narrower operator.pairing scope, allowing unprivileged users to approve node pairing. Attackers with operator.write permissions can bypass pairing approval restrictions to gain unauthorized access to exec-capable nodes.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.8: Affected (semver)
    • 2026.4.8: Not affected (semver)

    Update to 2026.4.8

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.8

    Update to 2026.4.8

Original sources

Check your server →