p PatchFirst

CVE-2026-42427

CVE-2026-42427 · OpenClaw < 2026.4.8 - Remote Code Execution via Build Tool Environment Variable Injection

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.8 contains a remote code execution vulnerability caused by missing environment variable denylist entries for HGRCPATH, CARGO_BUILD_RUSTC_WRAPPER, RUSTC_WRAPPER, and MAKEFLAGS. Attackers can inject malicious build tool environment variables to influence host exec commands and achieve arbitrary code execution.

CVSS 5.8 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.8: Affected (semver)
    • 2026.4.8: Not affected (semver)

    Update to 2026.4.8

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.8

    Update to 2026.4.8

Original sources

Check your server →