p PatchFirst

CVE-2026-42428

CVE-2026-42428 · OpenClaw < 2026.4.8 - Missing Integrity Verification in Package Downloads

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions before 2026.4.8 fail to enforce integrity verification on downloaded plugin archives. Attackers can install malicious or tampered plugin packages without detection, compromising the local assistant environment.

CVSS 7.5 · High · EPSS 0.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.8: Affected (semver)
    • 2026.4.8: Not affected (semver)

    Update to 2026.4.8

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.8

    Update to 2026.4.8

Original sources

Check your server →