p PatchFirst

CVE-2026-42432

CVE-2026-42432 · OpenClaw < 2026.4.8 - Command Escalation via Node Pairing Reconnect Bypass

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.8 contains a privilege escalation vulnerability allowing previously paired nodes to reconnect with exec-capable commands without the operator.admin scope requirement. Attackers can bypass re-pairing authentication to execute privileged commands on the local assistant system.

CVSS 7.3 · High · EPSS 0.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.8: Affected (semver)
    • 2026.4.8: Not affected (semver)

    Update to 2026.4.8

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.8

    Update to 2026.4.8

Original sources

Check your server →