CVE-2026-42569
CVE-2026-42569 · phpvms: /importer authorization bypass causing full database wipe
This page contains facts from public vulnerability sources. Check the original advisory before updating.
phpVMS is a PHP application to run and simulate an airline. Prior to version 7.0.6, a critical vulnerability in phpVMS allowed unauthenticated access to a legacy import feature. This issue has been patched in version 7.0.6.
CVSS 9.4 · Critical · EPSS 1.2% · Public exploit · Fix available
- Published
- Updated
Stack: php
Affected products and versions
phpvms
- Versions
- < 7.0.6: Affected
No fix published
nabeel/phpvms Packagist
- Versions
- 7.0.0
- 7.0.0-beta.2
- 7.0.0-beta.3
- 7.0.0-beta.4
- 7.0.0-beta.5
- 7.0.1
- 7.0.2
- 7.0.3
- 7.0.4
- 7.0.5
- v7.0.0-alpha2
- v7.0.0-beta
- Affected ranges
- ECOSYSTEM: < 7.0.6
Update to 7.0.6
Original sources
- https://github.com/phpvms/phpvms/security/advisories/GHSA-fv26-4939-62fh
- https://github.com/phpvms/phpvms/commit/f59ba8e0e8fc25c60c3faf14e526cfd49df3f7dc
- https://github.com/phpvms/phpvms/releases/tag/7.0.6
- https://github.com/phpvms/phpvms/releases/tag/7.0.7
- https://nvd.nist.gov/vuln/detail/CVE-2026-42569