p PatchFirst

CVE-2026-4267

CVE-2026-4267 · Query Monitor <= 3.20.3 - Reflected Cross-Site Scripting via Request URI

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Query Monitor – The developer tools panel for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘$_SERVER['REQUEST_URI']’ parameter in all versions up to, and including, 3.20.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

CVSS 7.2 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • query monitor

    Versions
    • ≥ 0, ≤ 3.20.3: Affected (semver)

    No fix published

  • johnbillion/query-monitor Packagist

    Versions
    • 2.10.0
    • 2.11.0
    • 2.11.1
    • 2.11.2
    • 2.11.3
    • 2.11.4
    • 2.12.0
    • 2.13.0
    • 2.13.1
    • 2.13.2
    • 2.13.3
    • 2.13.4
    • 2.14.0
    • 2.15.0
    • 2.16.0
    • 2.16.1
    • 2.16.2
    • 2.17.0
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    • 2.5.6
    • 2.6
    • 2.6.1
    • 2.6.10
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    • 2.6.6
    • 2.6.7
    • 2.6.8
    • 2.6.9
    • 2.7.0
    • 2.7.1
    • 2.7.2
    • 2.7.3
    • 2.7.4
    • 2.8.0
    • 2.8.1
    • 2.9.0
    • 2.9.1
    • 3.0.0
    • 3.0.1
    • 3.1.0
    • 3.1.1
    • 3.10.0
    • 3.10.1
    • 3.11.0
    • 3.11.1
    • 3.11.2
    • 3.12.0
    • 3.12.1
    • 3.12.2
    • 3.12.3
    • 3.13.0
    • 3.13.1
    • 3.14.0
    • 3.14.1
    • 3.15.0
    • 3.16.0
    • 3.16.1
    • 3.16.2
    • 3.16.3
    • 3.16.4
    • 3.17.0
    • 3.17.1
    • 3.17.2
    • 3.18.0
    • 3.19.0
    • 3.2.0
    • 3.2.1
    • 3.2.2
    • 3.20.0
    • 3.20.1
    • 3.20.2
    • 3.20.3
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3.5
    • 3.3.6
    • 3.3.7
    • 3.4.0
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.6.0
    • 3.6.1
    • 3.6.2
    • 3.6.3
    • 3.6.4
    • 3.6.5
    • 3.6.6
    • 3.6.7
    • 3.6.8
    • 3.7.0
    • 3.7.1
    • 3.8.0
    • 3.8.1
    • 3.8.2
    • 3.9.0
    Affected ranges
    • ECOSYSTEM: < 3.20.4

    Update to 3.20.4

Original sources

Check your server →