CVE-2026-42944
CVE-2026-42944 · Heap overflow with multiple NSID, COOKIE, PADDING EDNS options
This page contains facts from public vulnerability sources. Check the original advisory before updating.
NLnet Labs Unbound 1.14.0 up to and including version 1.25.0 has a vulnerability that results in heap overflow when encoding multiple NSID and/or DNS Cookie EDNS and/or EDNS Padding options in the reply packet. The relevant options ('nsid', 'answer-cookie', 'pad-responses' (default)) need to be enabled for the vulnerability to be exploited. An adversary who can query Unbound can exploit the vulnerability by attaching multiple NSID and/or DNS Cookie EDNS and/or EDNS Padding options to the query. A flaw in the size calculation of the EDNS field truncates the correct value which allows the encoder to overflow the available space when writing. Those two combined lead to a heap overflow write of Unbound controlled data and eventually a crash. Unbound 1.25.1 contains a patch with a fix to de-duplicate the EDNS options and a fix to prevent truncation of the EDNS field size calculation.
CVSS 8.7 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
unbound
- Versions
- ≥ 1.14.0, < 1.25.1: Affected (semver)
Update to 1.25.1
unbound Debian:12
- Versions
- 1.17.1-2
- 1.17.1-2+deb12u1
- 1.17.1-2+deb12u2
- 1.17.1-2+deb12u3
- 1.17.1-2+deb12u4
- 1.17.1-2+loong64
- 1.18.0-1
- 1.18.0-2
- 1.19.1-1
- 1.19.2-1
- 1.20.0-1
- 1.21.1-1
- 1.22.0-1
- 1.22.0-2
- 1.23.1-1
- 1.24.0-1
- 1.24.0-2
- 1.24.1-1
- 1.24.1-2
- 1.24.2-1
- 1.25.0-1
- 1.25.1-1
- 1.25.2-1
- 1.26.0-1
- 1.26.0-2
- 1.26.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
unbound Debian:13
- Versions
- 1.22.0-2
- 1.22.0-2+deb13u1
- 1.22.0-2+deb13u2
- Affected ranges
- ECOSYSTEM: < 1.22.0-2+deb13u3
Update to 1.22.0-2+deb13u3
unbound Debian:14
- Versions
- 1.22.0-2
- 1.23.1-1
- 1.24.0-1
- 1.24.0-2
- 1.24.1-1
- 1.24.1-2
- 1.24.2-1
- 1.25.0-1
- Affected ranges
- ECOSYSTEM: < 1.25.1-1
Update to 1.25.1-1
unbound Ubuntu:24.04:LTS
- Versions
- 1.17.1-2
- 1.18.0-2ubuntu1
- 1.18.0-2ubuntu2
- 1.19.1-1ubuntu1
- 1.19.2-1ubuntu1
- 1.19.2-1ubuntu3
- 1.19.2-1ubuntu3.1
- 1.19.2-1ubuntu3.2
- 1.19.2-1ubuntu3.3
- 1.19.2-1ubuntu3.4
- 1.19.2-1ubuntu3.5
- 1.19.2-1ubuntu3.6
- 1.19.2-1ubuntu3.7
- Affected ranges
- ECOSYSTEM: < 1.19.2-1ubuntu3.8
Update to 1.19.2-1ubuntu3.8
unbound Ubuntu:25.10
- Versions
- 1.22.0-1ubuntu1
- 1.22.0-2ubuntu1
- 1.22.0-2ubuntu2
- 1.22.0-2ubuntu2.1
- 1.22.0-2ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 1.22.0-2ubuntu2.3
Update to 1.22.0-2ubuntu2.3
unbound Ubuntu:26.04:LTS
- Versions
- 1.22.0-2ubuntu2
- 1.22.0-2ubuntu4
- 1.24.2-1ubuntu1
- 1.24.2-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.24.2-1ubuntu2.1
Update to 1.24.2-1ubuntu2.1
Original sources
- https://www.nlnetlabs.nl/downloads/unbound/CVE-2026-42944.txt
- https://access.redhat.com/security/cve/CVE-2026-42944
- https://bugzilla.redhat.com/show_bug.cgi?id=2479774
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42944.json
- https://access.redhat.com/errata/RHSA-2026:23231
- https://access.redhat.com/errata/RHSA-2026:24365
- https://access.redhat.com/errata/RHSA-2026:24369
- https://access.redhat.com/errata/RHSA-2026:19752
- https://nvd.nist.gov/vuln/detail/CVE-2026-42944