p PatchFirst

CVE-2026-43568

CVE-2026-43568 · OpenClaw 2026.4.5 through 2026.4.9 - Privilege Escalation via Memory Dreaming Configuration in /dreaming Endpoint

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions 2026.4.5 before 2026.4.10 contain a privilege escalation vulnerability allowing write-scoped operators to modify persistent memory dreaming settings. Attackers with write-scoped gateway access can toggle admin-class configuration mutations through the /dreaming endpoint to escalate privileges.

CVSS 7.1 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 2026.4.5, < 2026.4.10: Affected (semver)
    • 2026.4.10: Not affected (semver)

    Update to 2026.4.10

  • openclaw npm

    Affected ranges
    • SEMVER: ≥ 2026.4.5, < 2026.4.10

    Update to 2026.4.10

Original sources

Check your server →